summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 11 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index f0cf5e8..a1bfd42 100644
--- a/setup.py
+++ b/setup.py
@@ -7,11 +7,17 @@
# which accompanies this distribution, and is available at
# http://www.apache.org/licenses/LICENSE-2.0
-from setuptools import setup
+import setuptools
__author__ = 'spisarski'
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
-setup(
- setup_requires=['pbr>=1.9', 'setuptools>=17.1'],
- pbr=True,
-)
+setuptools.setup(
+ setup_requires=['pbr>=2.0.0'],
+ pbr=True)