aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py23
1 files changed, 23 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 00000000..9ff16995
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,23 @@
+import os
+from setuptools import setup
+
+# Utility function to read the README file.
+# Used for the long_description. It's nice, because now 1) we have a top level
+# README file and 2) it's easier to type in the README file than to put a raw
+# string in below ...
+def read(fname):
+ return open(os.path.join(os.path.dirname(__file__), fname)).read()
+
+setup(
+ name = "vnf manager simulator",
+ version = "1.0",
+ author = "Manuel Buil, Brady A. Johnson",
+ author_email = "manuel.buil@ericsson.com, brady.allen.johnson@ericsson.com",
+ description = ("A script which simulates an orchestrator"),
+ license = "Apache License Version 2.0",
+ keywords = "example documentation tutorial",
+ url = "https://gerrit.opnfv.org/gerrit/#/c/2519",
+ packages = [".."],
+ scripts = [".."],
+ long_description=read('README'),
+)