diff options
author | jose.lausuch <jose.lausuch@ericsson.com> | 2016-12-13 12:31:39 +0100 |
---|---|---|
committer | jose.lausuch <jose.lausuch@ericsson.com> | 2016-12-15 12:37:52 +0100 |
commit | acf339f2840d0fe7a46187a0597704cf5b486214 (patch) | |
tree | de114d6482bcd7cfd9d057f756d8b6f8864911cb /setup.py | |
parent | 1350624dbcf49c27ae0333719c2d7dda86ca7b0e (diff) |
Make SFC installable as a python module
New directory structure:
<root>/sfc
<root>/sfc/lib/
<root>/sfc/tests
<root>/sfc/tests/functest
JIRA: SFC-60
After installing sfc, the imports would be:
import sfc.tests.functest.x
import sfc.lib.x
Change-Id: Ib15172239aefdef65056d6598210a1b28a4b2eff
Signed-off-by: jose.lausuch <jose.lausuch@ericsson.com>
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 33 |
1 files changed, 14 insertions, 19 deletions
@@ -1,25 +1,20 @@ -import os -from setuptools import setup +############################################################################## +# All rights reserved. This program and the accompanying materials +# are made available under the terms of the Apache License, Version 2.0 +# which accompanies this distribution, and is available at +# http://www.apache.org/licenses/LICENSE-2.0 +############################################################################## -# Utility function to read the README file. -# Used for the long_description. It's nice, because now 1) we have a top level -# README file and 2) it's easier to type in the README file than to put a raw -# string in below ... +from setuptools import setup, find_packages -def read(fname): - return open(os.path.join(os.path.dirname(__file__), fname)).read() setup( - name="vnf manager simulator", - version="1.0", - author="Manuel Buil, Brady A. Johnson", - author_email="manuel.buil@ericsson.com, brady.allen.johnson@ericsson.com", - description=("A script which simulates an orchestrator"), - license="Apache License Version 2.0", - keywords="example documentation tutorial", - url="https://gerrit.opnfv.org/gerrit/#/c/2519", - packages=[".."], - scripts=[".."], - long_description=read('README'), + name="sfc", + version="danube", + packages=find_packages(), + include_package_data=True, + package_data={ + }, + url="https://www.opnfv.org" ) |