summaryrefslogtreecommitdiffstats
path: root/xci/playbooks/roles/configure-network/templates/debian/controller00.interface.j2
diff options
context:
space:
mode:
authorMarkos Chandras <mchandras@suse.de>2018-02-13 21:42:05 +0000
committerMarkos Chandras <mchandras@suse.de>2018-02-13 21:44:39 +0000
commit5d27230f41687f11def9549a169bd5b8831c9965 (patch)
tree06ba1b0ae26b0b14aa7bf454d84fc5d5831ebadd /xci/playbooks/roles/configure-network/templates/debian/controller00.interface.j2
parent884c8bbced3fe5320cdb08629343b22ec859aeaf (diff)
xci: Bump OpenStack Ansbile SHAs
* Bump up upstream SHAs * With these upstream SHAs, OSA installs neutron-agent container on controller node which would require eth12 interface on controller for establishing vlan provider networks. so adding eth12 interface and linking it with br-vlan over br-vlan-veth link. Change-Id: Iaf7cbe6e41dcfd15ec6527c5a50701f2d05eaad8 Signed-off-by: Markos Chandras <mchandras@suse.de> Signed-off-by: Periyasamy Palanisamy <periyasamy.palanisamy@ericsson.com>
Diffstat (limited to 'xci/playbooks/roles/configure-network/templates/debian/controller00.interface.j2')
-rw-r--r--xci/playbooks/roles/configure-network/templates/debian/controller00.interface.j28
1 files changed, 8 insertions, 0 deletions
diff --git a/xci/playbooks/roles/configure-network/templates/debian/controller00.interface.j2 b/xci/playbooks/roles/configure-network/templates/debian/controller00.interface.j2
index 5d42a5d2..b461b201 100644
--- a/xci/playbooks/roles/configure-network/templates/debian/controller00.interface.j2
+++ b/xci/playbooks/roles/configure-network/templates/debian/controller00.interface.j2
@@ -54,6 +54,14 @@ iface br-vlan inet static
netmask 255.255.255.0
gateway 192.168.122.1
dns-nameserver 8.8.8.8 8.8.4.4
+ # Create veth pair, don't bomb if already exists
+ pre-up ip link add br-vlan-veth type veth peer name eth12 || true
+ # Set both ends UP
+ pre-up ip link set br-vlan-veth up
+ pre-up ip link set eth12 up
+ # Delete veth pair on DOWN
+ post-down ip link del br-vlan-veth || true
+ bridge_ports br-vlan-veth
# OpenStack Storage bridge
auto br-storage