aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorjose.lausuch <jose.lausuch@ericsson.com>2016-11-16 12:53:12 +0100
committerjose.lausuch <jose.lausuch@ericsson.com>2016-11-16 16:46:58 +0100
commit9de1ded9cf18dfce75d1a85c54242c74e3133fcd (patch)
treef59d9dfa26a8f6c647b446e1a7917388e9c20acf /setup.py
parent4da1cc669354d2e632bb0bb93e9e09d24d3642f6 (diff)
Add setup.py for common OPNFV modules
JIRA: RELENG-161 Change-Id: I2423493d0c9c9c4ce78fe8c2669b9ed24e697b58 Signed-off-by: jose.lausuch <jose.lausuch@ericsson.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py21
1 files changed, 21 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..26f8a6e
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,21 @@
+##############################################################################
+# All rights reserved. This program and the accompanying materials
+# are made available under the terms of the Apache License, Version 2.0
+# which accompanies this distribution, and is available at
+# http://www.apache.org/licenses/LICENSE-2.0
+##############################################################################
+
+
+from setuptools import setup, find_packages
+
+
+setup(
+ name="opnfv",
+ version="danube",
+ packages=find_packages(),
+ include_package_data=True,
+ package_data={
+ },
+ url="https://www.opnfv.org",
+ install_requires=["paramiko>=2.0.1"]
+)