aboutsummaryrefslogtreecommitdiffstats
path: root/cli/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'cli/setup.py')
-rw-r--r--cli/setup.py23
1 files changed, 23 insertions, 0 deletions
diff --git a/cli/setup.py b/cli/setup.py
new file mode 100644
index 00000000..1c2808b8
--- /dev/null
+++ b/cli/setup.py
@@ -0,0 +1,23 @@
+##############################################################################
+# Copyright (c) 2016 ZTE Corp and others.
+#
+# All rights reserved. This program and the accompanying materials
+# are made available under the terms of the Apache License, Version 2.0
+# which accompanies this distribution, and is available at
+# http://www.apache.org/licenses/LICENSE-2.0
+##############################################################################
+
+from setuptools import setup
+
+setup(
+ name='qtip',
+ py_modules=['cli_entry'],
+ include_package_data=True,
+ install_requires=[
+ 'click',
+ ],
+ entry_points='''
+ [console_scripts]
+ qtip=cli_entry:cli
+ ''',
+)