aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorYujun Zhang <zhang.yujunz@zte.com.cn>2016-11-01 13:40:40 +0800
committerYujun Zhang <zhang.yujunz@zte.com.cn>2016-11-01 15:59:54 +0800
commit04b1e4764cf5b2537d4649530dea78899bba3de3 (patch)
tree0af5498d0c80a2907b10e4eddfecd4591bfaf76d /setup.py
parent74903ac9221be98e6663df80b641335ee3b93c13 (diff)
Create setuptool configuration for qtip-cli
- currently only the cli is installed via setuptool - api server in docker container will be installed via cli[1] - normalized version string[2] for cli [1]: https://jira.opnfv.org/browse/QTIP-133 [2]: https://setuptools.readthedocs.io/en/latest/setuptools.html#specifying-your-project-s-version JIRA: QTIP-137 Change-Id: Ia53ae14fca271a250d59cb08e7c6c5cd7dad97a9 Signed-off-by: Yujun Zhang <zhang.yujunz@zte.com.cn>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py22
1 files changed, 16 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 85dc966b..fb6711c6 100644
--- a/setup.py
+++ b/setup.py
@@ -1,10 +1,20 @@
#!/usr/bin/env python
-from distutils.core import setup
+from setuptools import setup
-setup(name='qtip',
- py_modules=['qtip'],
- version='1.0',
- author='opnfv',
- packages=['func', 'scripts.ref_results', 'utils.report'])
+setup(
+ name='qtip-cli',
+ version='0.1.dev0',
+ description='Platform Performance Benchmarking for OPNFV',
+ author='OPNFV',
+ author_email='zhang.yujunz@zte.com.cn',
+ install_requires=['click'],
+ packages=['cli'],
+ entry_points={
+ 'console_scripts': ['qtip=cli.entry:cli']
+ },
+ license='Apache-2.0',
+ keywords="performance benchmark opnfv",
+ url="https://wiki.opnfv.org/display/qtip"
+)