summaryrefslogtreecommitdiffstats
path: root/cli/setup.py
diff options
context:
space:
mode:
authorSerenaFeng <feng.xiaowei@zte.com.cn>2016-10-13 14:46:10 +0800
committerSerenaFeng <feng.xiaowei@zte.com.cn>2016-10-17 16:02:21 +0800
commitcc78db7c49dcff6d96390e31ad31870734054680 (patch)
treeaa0d6c335514ed8effd577b3fc3d0ed436d1c564 /cli/setup.py
parentf7b4e61fcc20c5814d9b7ed5ebefbec1b549cd03 (diff)
add CLI framework for qtip
add cli framework to implement commands JIRA: QTIP-125 Change-Id: I442e9df9d3ea8443adb7a7aedd5849457dcead7e Signed-off-by: SerenaFeng <feng.xiaowei@zte.com.cn>
Diffstat (limited to 'cli/setup.py')
-rw-r--r--cli/setup.py23
1 files changed, 23 insertions, 0 deletions
diff --git a/cli/setup.py b/cli/setup.py
new file mode 100644
index 00000000..1c2808b8
--- /dev/null
+++ b/cli/setup.py
@@ -0,0 +1,23 @@
+##############################################################################
+# Copyright (c) 2016 ZTE Corp and others.
+#
+# All rights reserved. This program and the accompanying materials
+# are made available under the terms of the Apache License, Version 2.0
+# which accompanies this distribution, and is available at
+# http://www.apache.org/licenses/LICENSE-2.0
+##############################################################################
+
+from setuptools import setup
+
+setup(
+ name='qtip',
+ py_modules=['cli_entry'],
+ include_package_data=True,
+ install_requires=[
+ 'click',
+ ],
+ entry_points='''
+ [console_scripts]
+ qtip=cli_entry:cli
+ ''',
+)