summaryrefslogtreecommitdiffstats
path: root/build/patches/ovs_nsh_patches/openvswitch-kmod.spec
diff options
context:
space:
mode:
Diffstat (limited to 'build/patches/ovs_nsh_patches/openvswitch-kmod.spec')
-rw-r--r--build/patches/ovs_nsh_patches/openvswitch-kmod.spec92
1 files changed, 92 insertions, 0 deletions
diff --git a/build/patches/ovs_nsh_patches/openvswitch-kmod.spec b/build/patches/ovs_nsh_patches/openvswitch-kmod.spec
new file mode 100644
index 0000000..9517b87
--- /dev/null
+++ b/build/patches/ovs_nsh_patches/openvswitch-kmod.spec
@@ -0,0 +1,92 @@
+# Generated automatically -- do not modify! -*- buffer-read-only: t -*-
+# Spec file for Open vSwitch.
+
+# Copyright (C) 2009, 2010, 2015 Nicira Networks, Inc.
+#
+# Copying and distribution of this file, with or without modification,
+# are permitted in any medium without royalty provided the copyright
+# notice and this notice are preserved. This file is offered as-is,
+# without warranty of any kind.
+
+%global debug_package %{nil}
+
+#%define kernel 3.1.5-1.fc16.x86_64
+#define kernel %{kernel_source}
+%{?kversion:%define kernel %kversion}
+
+%define ver 2.5.90
+%define rel 1
+%define snapver 11975.NSH7d433ae5
+
+%define srcver %{ver}%{?snapver:-%{snapver}}
+
+Name: openvswitch-kmod
+Summary: Open vSwitch Kernel Modules
+Group: System Environment/Daemons
+URL: http://www.openvswitch.org/
+Vendor: OpenSource Security Ralf Spenneberg <ralf@os-s.net>
+Version: %{ver}
+
+# The entire source code is ASL 2.0 except datapath/ which is GPLv2
+License: GPLv2
+Release: %{?snapver:0.%{snapver}.}%{rel}%{?dist}
+Source0: %{name}-%{srcver}.tar.gz
+#Source1: openvswitch-init
+Buildroot: /tmp/openvswitch-xen-rpm
+
+# Add vxLan gpe NSH
+Patch1: 0001-ovs-vxlan-gpe-vxlan-extension-to-support-vxlan-gpe-t.patch
+Patch2: 0002-ovs-nsh-support-push-and-pop-actions-for-vxlan-gpe-a.patch
+Patch3: 0003-Add-userspace-dataplane-nsh-support-and-remove-push_.patch
+Patch4: 0004-Fix-too-large-stack-frame-size.patch
+Patch5: 0005-Ethernet-header-must-be-kept-in-VxLAN-gpe-eth-NSH-fo.patch
+Patch6: 0006-Fix-VxLAN-gpe-Eth-NSH-issues.patch
+
+%description
+Open vSwitch provides standard network bridging functions augmented with
+support for the OpenFlow protocol for remote per-flow control of
+traffic. This package contains the kernel modules.
+
+%prep
+%setup -q -n %{name}-%{srcver}
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
+
+%build
+autoreconf -i
+%configure --with-linux=/lib/modules/%{kernel}/build --enable-ssl
+make %{_smp_mflags} -C datapath/linux
+
+%install
+rm -rf $RPM_BUILD_ROOT
+make INSTALL_MOD_PATH=$RPM_BUILD_ROOT -C datapath/linux modules_install
+mkdir -p $RPM_BUILD_ROOT/etc/depmod.d
+for module in $RPM_BUILD_ROOT/lib/modules/%{kernel}/extra/*.ko
+do
+ modname="$(basename ${module})"
+ echo "override ${modname%.ko} * extra" >> \
+ $RPM_BUILD_ROOT/etc/depmod.d/kmod-openvswitch.conf
+done
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+# Ensure that modprobe will find our modules.
+depmod %{kernel}
+
+%files
+%defattr(0644,root,root)
+/lib/modules/%{kernel}/extra/*.ko
+/etc/depmod.d/kmod-openvswitch.conf
+%exclude /lib/modules/%{kernel}/modules.*
+
+%changelog
+* Wed Sep 21 2011 Kyle Mestery <kmestery@cisco.com>
+- Updated for F15
+* Wed Jan 12 2011 Ralf Spenneberg <ralf@os-s.net>
+- First build on F14