aboutsummaryrefslogtreecommitdiffstats
path: root/charms/trusty/keepalived/hooks/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'charms/trusty/keepalived/hooks/setup.py')
-rw-r--r--charms/trusty/keepalived/hooks/setup.py17
1 files changed, 17 insertions, 0 deletions
diff --git a/charms/trusty/keepalived/hooks/setup.py b/charms/trusty/keepalived/hooks/setup.py
new file mode 100644
index 0000000..50854d9
--- /dev/null
+++ b/charms/trusty/keepalived/hooks/setup.py
@@ -0,0 +1,17 @@
+def pre_install():
+ """
+ Do any setup required before the install hook.
+ """
+ install_charmhelpers()
+
+
+def install_charmhelpers():
+ """
+ Install the charmhelpers library, if not present.
+ """
+ try:
+ import charmhelpers # noqa
+ except ImportError:
+ import subprocess
+ subprocess.check_call(['apt-get', 'install', '-y', 'python-pip'])
+ subprocess.check_call(['pip', 'install', 'charmhelpers'])