aboutsummaryrefslogtreecommitdiffstats
path: root/charms/trusty/keepalived/hooks/setup.py
diff options
context:
space:
mode:
authorStuart Mackie <wsmackie@juniper.net>2016-10-07 12:24:58 -0700
committerStuart Mackie <wsmackie@juniper.net>2016-10-07 12:24:58 -0700
commit4faa7f927149a5c4ef7a03523f7bc14523cb9baa (patch)
tree0be55aa0809cc395e45baeae63db660b4e72fe83 /charms/trusty/keepalived/hooks/setup.py
parent82f1a7eb5535b30a95b1e71ff18c315d40d1e6f0 (diff)
Charms for Contrail 3.1 with Mitaka
Change-Id: Id37f3b9743d1974e31fcd7cd9c54be41bb0c47fb Signed-off-by: Stuart Mackie <wsmackie@juniper.net>
Diffstat (limited to 'charms/trusty/keepalived/hooks/setup.py')
-rw-r--r--charms/trusty/keepalived/hooks/setup.py17
1 files changed, 17 insertions, 0 deletions
diff --git a/charms/trusty/keepalived/hooks/setup.py b/charms/trusty/keepalived/hooks/setup.py
new file mode 100644
index 0000000..50854d9
--- /dev/null
+++ b/charms/trusty/keepalived/hooks/setup.py
@@ -0,0 +1,17 @@
+def pre_install():
+ """
+ Do any setup required before the install hook.
+ """
+ install_charmhelpers()
+
+
+def install_charmhelpers():
+ """
+ Install the charmhelpers library, if not present.
+ """
+ try:
+ import charmhelpers # noqa
+ except ImportError:
+ import subprocess
+ subprocess.check_call(['apt-get', 'install', '-y', 'python-pip'])
+ subprocess.check_call(['pip', 'install', 'charmhelpers'])