summaryrefslogtreecommitdiffstats
path: root/opnfv-theme/setup.py
diff options
context:
space:
mode:
authorTrevor Bramwell <tbramwell@linuxfoundation.org>2018-02-02 12:16:52 -0800
committerRyota MIBU <r-mibu@cq.jp.nec.com>2018-02-06 10:42:15 +0900
commitc1cbdfaf687437baba73fbbe5551907b6913f0a4 (patch)
treef95736a6c6af21304ed1dc7677c845559fd87bbe /opnfv-theme/setup.py
parentfb7da06424c1a12ca0f2e1a2c4f1dd99f0adbb51 (diff)
OPNFV Sphinx Theme
This is a standalone theme for OPNFV docs based on the Sphinx Bootstrap Theme used in opnfvdocs. Change-Id: Ie145c0dc9c1e4c1ed0d8d72d687524b4ef5883de Signed-off-by: Trevor Bramwell <tbramwell@linuxfoundation.org>
Diffstat (limited to 'opnfv-theme/setup.py')
-rw-r--r--opnfv-theme/setup.py30
1 files changed, 30 insertions, 0 deletions
diff --git a/opnfv-theme/setup.py b/opnfv-theme/setup.py
new file mode 100644
index 000000000..5375c0940
--- /dev/null
+++ b/opnfv-theme/setup.py
@@ -0,0 +1,30 @@
+from setuptools import setup, find_packages
+
+from sphinx_opnfv_theme import __version__
+
+with open('README.rst') as f:
+ readme_text = f.read()
+
+setup(
+ name='sphinx_opnfv_theme',
+ description="OPNFV Theme for Sphinx",
+ long_description=readme_text,
+ url='https://docs.opnfv.org/',
+ author='Trevor Bramwell',
+ author_email='tbramwell@linuxfoundation.org',
+ version=__version__,
+ entry_points = {
+ 'sphinx.html_themes': [
+ 'opnfv = sphinx_opnfv_theme',
+ ]
+ },
+ packages=find_packages(),
+ install_requires = [
+ 'sphinx_bootstrap_theme',
+ 'sphinxcontrib.httpdomain',
+ ],
+ include_package_data=True,
+ package_data = {
+ 'sphinx_opnfv_theme': ['opnfv/**',]
+ },
+)