summaryrefslogtreecommitdiffstats
path: root/opnfv-theme/setup.py
diff options
context:
space:
mode:
authorSofia Wallin <sofia.wallin@ericsson.com>2018-02-22 11:45:31 +0000
committerGerrit Code Review <gerrit@opnfv.org>2018-02-22 11:45:31 +0000
commit9c329a1a4e8ca5cf65d93fceadc19413808f0df5 (patch)
tree7ffa78d99ed56c50b6a7045ad79aeb92b193df8a /opnfv-theme/setup.py
parent2346cd06fd37f39a708e66a282125ab9d647c81e (diff)
parentc1cbdfaf687437baba73fbbe5551907b6913f0a4 (diff)
Merge "OPNFV Sphinx Theme"
Diffstat (limited to 'opnfv-theme/setup.py')
-rw-r--r--opnfv-theme/setup.py30
1 files changed, 30 insertions, 0 deletions
diff --git a/opnfv-theme/setup.py b/opnfv-theme/setup.py
new file mode 100644
index 000000000..5375c0940
--- /dev/null
+++ b/opnfv-theme/setup.py
@@ -0,0 +1,30 @@
+from setuptools import setup, find_packages
+
+from sphinx_opnfv_theme import __version__
+
+with open('README.rst') as f:
+ readme_text = f.read()
+
+setup(
+ name='sphinx_opnfv_theme',
+ description="OPNFV Theme for Sphinx",
+ long_description=readme_text,
+ url='https://docs.opnfv.org/',
+ author='Trevor Bramwell',
+ author_email='tbramwell@linuxfoundation.org',
+ version=__version__,
+ entry_points = {
+ 'sphinx.html_themes': [
+ 'opnfv = sphinx_opnfv_theme',
+ ]
+ },
+ packages=find_packages(),
+ install_requires = [
+ 'sphinx_bootstrap_theme',
+ 'sphinxcontrib.httpdomain',
+ ],
+ include_package_data=True,
+ package_data = {
+ 'sphinx_opnfv_theme': ['opnfv/**',]
+ },
+)