summaryrefslogtreecommitdiffstats
path: root/opnfv-theme/setup.py
diff options
context:
space:
mode:
authorTrevor Bramwell <tbramwell@linuxfoundation.org>2018-03-28 10:27:51 -0700
committerTrevor Bramwell <tbramwell@linuxfoundation.org>2018-04-20 11:05:50 -0700
commitbd331b2451a17eaf5ed8f6fc8aa89f0499031c28 (patch)
tree3bcf69b472c8b4af97ce8842e49ec12049b750b2 /opnfv-theme/setup.py
parentb66a62102b39654b389f5cd186d7468f43b97522 (diff)
Update OPNFV Sphinx Theme
When the theme was initially created I was under the assumption the directory the theme lives under needs to match the name. This does not seem to be the case and in fact seems to cause issues with correctly importing and using the theme. Includes formatting updates to the README and linting. Change-Id: I67c834bfe9dc99252159394ecbf136d9a264e0a8 Signed-off-by: Trevor Bramwell <tbramwell@linuxfoundation.org>
Diffstat (limited to 'opnfv-theme/setup.py')
-rw-r--r--opnfv-theme/setup.py18
1 files changed, 9 insertions, 9 deletions
diff --git a/opnfv-theme/setup.py b/opnfv-theme/setup.py
index 5375c0940..55f55bc92 100644
--- a/opnfv-theme/setup.py
+++ b/opnfv-theme/setup.py
@@ -2,29 +2,29 @@ from setuptools import setup, find_packages
from sphinx_opnfv_theme import __version__
-with open('README.rst') as f:
- readme_text = f.read()
setup(
name='sphinx_opnfv_theme',
description="OPNFV Theme for Sphinx",
- long_description=readme_text,
+ long_description=open('README.rst').read(),
url='https://docs.opnfv.org/',
author='Trevor Bramwell',
author_email='tbramwell@linuxfoundation.org',
version=__version__,
- entry_points = {
+ entry_points={
'sphinx.html_themes': [
'opnfv = sphinx_opnfv_theme',
]
},
packages=find_packages(),
- install_requires = [
+ install_requires=[
'sphinx_bootstrap_theme',
- 'sphinxcontrib.httpdomain',
+ 'sphinxcontrib-httpdomain',
],
include_package_data=True,
- package_data = {
- 'sphinx_opnfv_theme': ['opnfv/**',]
- },
+ package_data={'sphinx_opnfv_theme': [
+ 'theme.conf',
+ 'static/*',
+ '*.html',
+ ]},
)