aboutsummaryrefslogtreecommitdiffstats
path: root/framework/src/suricata/qa/coccinelle/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'framework/src/suricata/qa/coccinelle/Makefile.am')
-rw-r--r--framework/src/suricata/qa/coccinelle/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/framework/src/suricata/qa/coccinelle/Makefile.am b/framework/src/suricata/qa/coccinelle/Makefile.am
new file mode 100644
index 00000000..8ceebe06
--- /dev/null
+++ b/framework/src/suricata/qa/coccinelle/Makefile.am
@@ -0,0 +1,21 @@
+EXTRA_DIST= access-pkt-packet.cocci \
+ action-pkt.cocci \
+ banned-functions.cocci \
+ direct-packet.cocci \
+ malloc-error-check.cocci \
+ pktnotset-packet.cocci \
+ size_t.cocci \
+ struct-flags.cocci \
+ sz3.cocci \
+ run_check.sh struct-flags.py
+
+if HAVE_COCCINELLE
+struct-flags.cocci:
+ $(srcdir)/struct-flags.py > $(top_builddir)/qa/coccinelle/struct-flags.cocci
+
+check:
+ $(top_srcdir)/qa/coccinelle/run_check.sh
+
+distclean-local:
+ -rm $(top_builddir)/qa/coccinelle/struct-flags.cocci
+endif