summaryrefslogtreecommitdiffstats
path: root/framework/src/suricata/contrib/tile_pcie_logd/Makefile.am
diff options
context:
space:
mode:
authorAshlee Young <ashlee@onosfw.com>2015-09-09 22:21:41 -0700
committerAshlee Young <ashlee@onosfw.com>2015-09-09 22:21:41 -0700
commit8879b125d26e8db1a5633de5a9c692eb2d1c4f83 (patch)
treec7259d85a991b83dfa85ab2e339360669fc1f58e /framework/src/suricata/contrib/tile_pcie_logd/Makefile.am
parent13d05bc8458758ee39cb829098241e89616717ee (diff)
suricata checkin based on commit id a4bce14770beee46a537eda3c3f6e8e8565d5d0a
Change-Id: I9a214fa0ee95e58fc640e50bd604dac7f42db48f
Diffstat (limited to 'framework/src/suricata/contrib/tile_pcie_logd/Makefile.am')
-rw-r--r--framework/src/suricata/contrib/tile_pcie_logd/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/framework/src/suricata/contrib/tile_pcie_logd/Makefile.am b/framework/src/suricata/contrib/tile_pcie_logd/Makefile.am
new file mode 100644
index 00000000..81a63fcb
--- /dev/null
+++ b/framework/src/suricata/contrib/tile_pcie_logd/Makefile.am
@@ -0,0 +1,14 @@
+
+EXTRA_DIST = LICENSE README
+
+if BUILD_PCIE_LOGGING
+bin_PROGRAMS = tile_pcie_logd
+
+tile_pcie_logd_SOURCE = tile_pcie_logd.c
+
+AM_CFLAGS = -std=gnu99 -Wall -Werror -g -O2 -I$(TILERA_ROOT)/include \
+ -DTILEPCI_HOST
+
+tile_pcie_logd_LDDADD = -pthread
+
+endif