aboutsummaryrefslogtreecommitdiffstats
path: root/moonv4/moon_router/setup.py
diff options
context:
space:
mode:
authorWuKong <rebirthmonkey@gmail.com>2017-07-19 10:23:25 +0200
committerWuKong <rebirthmonkey@gmail.com>2017-07-19 10:23:25 +0200
commitffd694ebadb1d3b4e140104f9f0a81837c0e7258 (patch)
treedcd2affe2d8963ab0e0ba4b3cdc85fbd2b30b209 /moonv4/moon_router/setup.py
parent2513cb55eeea516fec50f2fa781ce778eeae1059 (diff)
add pip package
Change-Id: I8b4d3fa24f6ad7c7f9bb5dc93279c4a48bb0fe86 Signed-off-by: WuKong <rebirthmonkey@gmail.com>
Diffstat (limited to 'moonv4/moon_router/setup.py')
-rw-r--r--moonv4/moon_router/setup.py47
1 files changed, 47 insertions, 0 deletions
diff --git a/moonv4/moon_router/setup.py b/moonv4/moon_router/setup.py
new file mode 100644
index 00000000..0c3b61ba
--- /dev/null
+++ b/moonv4/moon_router/setup.py
@@ -0,0 +1,47 @@
+# Copyright 2015 Open Platform for NFV Project, Inc. and its contributors
+# This software is distributed under the terms and conditions of the 'Apache-2.0'
+# license which can be found in the file 'LICENSE' in this package distribution
+# or at 'http://www.apache.org/licenses/LICENSE-2.0'.
+
+from setuptools import setup, find_packages
+import moon_secrouter
+
+
+setup(
+
+ name='moon_secrouter',
+
+ version=moon_secrouter.__version__,
+
+ packages=find_packages(),
+
+ author="Thomas Duval",
+
+ author_email="thomas.duval@orange.com",
+
+ description="",
+
+ long_description=open('README.rst').read(),
+
+ # install_requires= ,
+
+ include_package_data=True,
+
+ url='https://git.opnfv.org/cgit/moon',
+
+ classifiers=[
+ "Programming Language :: Python",
+ "Development Status :: 1 - Planning",
+ "License :: OSI Approved",
+ "Natural Language :: French",
+ "Operating System :: OS Independent",
+ "Programming Language :: Python :: 3",
+ ],
+
+ entry_points={
+ 'console_scripts': [
+ 'moon_secrouter = moon_secrouter.server:main',
+ ],
+ }
+
+)