summaryrefslogtreecommitdiffstats
path: root/fuel-build/patch-packages/python-nova
diff options
context:
space:
mode:
Diffstat (limited to 'fuel-build/patch-packages/python-nova')
-rw-r--r--fuel-build/patch-packages/python-nova/Makefile2
-rw-r--r--fuel-build/patch-packages/python-nova/nova-console.patch45
2 files changed, 29 insertions, 18 deletions
diff --git a/fuel-build/patch-packages/python-nova/Makefile b/fuel-build/patch-packages/python-nova/Makefile
index 9bcff70..17ef1e1 100644
--- a/fuel-build/patch-packages/python-nova/Makefile
+++ b/fuel-build/patch-packages/python-nova/Makefile
@@ -22,7 +22,7 @@ clean:
.PHONY: release
release:
- ../tools/deb_unpack python-nova_2014.1.3-fuel5.1.1~mira3_all.deb $(ORIGISO)
+ ../tools/deb_unpack python-nova_*.deb $(ORIGISO)
patch -s -p0 < nova-console.patch
../tools/deb_pack $(VERSION)
@cp *.deb ../release/packages
diff --git a/fuel-build/patch-packages/python-nova/nova-console.patch b/fuel-build/patch-packages/python-nova/nova-console.patch
index a05af3b..fbc0318 100644
--- a/fuel-build/patch-packages/python-nova/nova-console.patch
+++ b/fuel-build/patch-packages/python-nova/nova-console.patch
@@ -1,17 +1,28 @@
---- package/usr/share/pyshared/nova/virt/libvirt/driver.py.org
-+++ package/usr/share/pyshared/nova/virt/libvirt/driver.py
-@@ -3280,10 +3280,10 @@
- # client app is connected. Thus we can't get away
- # with a single type=pty console. Instead we have
- # to configure two separate consoles.
-- consolelog = vconfig.LibvirtConfigGuestSerial()
-- consolelog.type = "file"
-- consolelog.source_path = self._get_console_log_path(instance)
-- guest.add_device(consolelog)
-+ #consolelog = vconfig.LibvirtConfigGuestSerial()
-+ #consolelog.type = "file"
-+ #consolelog.source_path = self._get_console_log_path(instance)
-+ #guest.add_device(consolelog)
-
- consolepty = vconfig.LibvirtConfigGuestSerial()
- consolepty.type = "pty"
+*** package/usr/share/pyshared/nova/virt/libvirt/driver.py.orig 2015-02-16 14:19:53.203052869 +0100
+--- package/usr/share/pyshared/nova/virt/libvirt/driver.py 2015-02-16 14:22:53.065017671 +0100
+***************
+*** 3959,3968 ****
+ # client app is connected. Thus we can't get away
+ # with a single type=pty console. Instead we have
+ # to configure two separate consoles.
+! consolelog = vconfig.LibvirtConfigGuestSerial()
+! consolelog.type = "file"
+! consolelog.source_path = self._get_console_log_path(instance)
+! guest.add_device(consolelog)
+
+ consolepty = vconfig.LibvirtConfigGuestSerial()
+ else:
+--- 3959,3971 ----
+ # client app is connected. Thus we can't get away
+ # with a single type=pty console. Instead we have
+ # to configure two separate consoles.
+! # Disabled by OPNFV BEGIN
+! # consolelog = vconfig.LibvirtConfigGuestSerial()
+! # consolelog.type = "file"
+! # consolelog.source_path = self._get_console_log_path(instance)
+! # guest.add_device(consolelog)
+! pass
+! # Disabled by OPNFV END
+
+ consolepty = vconfig.LibvirtConfigGuestSerial()
+ else: