summaryrefslogtreecommitdiffstats
path: root/fuel-build/patch-packages/python-nova
diff options
context:
space:
mode:
Diffstat (limited to 'fuel-build/patch-packages/python-nova')
-rw-r--r--fuel-build/patch-packages/python-nova/Makefile29
-rw-r--r--fuel-build/patch-packages/python-nova/nova-console.patch28
2 files changed, 0 insertions, 57 deletions
diff --git a/fuel-build/patch-packages/python-nova/Makefile b/fuel-build/patch-packages/python-nova/Makefile
deleted file mode 100644
index 17ef1e1..0000000
--- a/fuel-build/patch-packages/python-nova/Makefile
+++ /dev/null
@@ -1,29 +0,0 @@
-##############################################################################
-# Copyright (c) 2015 Ericsson AB and others.
-# stefan.k.berg@ericsson.com
-# jonas.bjurel@ericsson.com
-# All rights reserved. This program and the accompanying materials
-# are made available under the terms of the Apache License, Version 2.0
-# which accompanies this distribution, and is available at
-# http://www.apache.org/licenses/LICENSE-2.0
-##############################################################################
-
-TOP := $(shell pwd)
-
-.PHONY: all
-all:
-
-.PHONY: clean
-clean:
- @rm -rf package
- @rm -rf *.deb
- @rm -rf patch-replacements
- @rm -rf .package
-
-.PHONY: release
-release:
- ../tools/deb_unpack python-nova_*.deb $(ORIGISO)
- patch -s -p0 < nova-console.patch
- ../tools/deb_pack $(VERSION)
- @cp *.deb ../release/packages
- @cat patch-replacements >> ../release/patch-replacements
diff --git a/fuel-build/patch-packages/python-nova/nova-console.patch b/fuel-build/patch-packages/python-nova/nova-console.patch
deleted file mode 100644
index fbc0318..0000000
--- a/fuel-build/patch-packages/python-nova/nova-console.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-*** package/usr/share/pyshared/nova/virt/libvirt/driver.py.orig 2015-02-16 14:19:53.203052869 +0100
---- package/usr/share/pyshared/nova/virt/libvirt/driver.py 2015-02-16 14:22:53.065017671 +0100
-***************
-*** 3959,3968 ****
- # client app is connected. Thus we can't get away
- # with a single type=pty console. Instead we have
- # to configure two separate consoles.
-! consolelog = vconfig.LibvirtConfigGuestSerial()
-! consolelog.type = "file"
-! consolelog.source_path = self._get_console_log_path(instance)
-! guest.add_device(consolelog)
-
- consolepty = vconfig.LibvirtConfigGuestSerial()
- else:
---- 3959,3971 ----
- # client app is connected. Thus we can't get away
- # with a single type=pty console. Instead we have
- # to configure two separate consoles.
-! # Disabled by OPNFV BEGIN
-! # consolelog = vconfig.LibvirtConfigGuestSerial()
-! # consolelog.type = "file"
-! # consolelog.source_path = self._get_console_log_path(instance)
-! # guest.add_device(consolelog)
-! pass
-! # Disabled by OPNFV END
-
- consolepty = vconfig.LibvirtConfigGuestSerial()
- else: