summaryrefslogtreecommitdiffstats
path: root/fuel-build/patch-packages/python-nova
diff options
context:
space:
mode:
authorJonas Bjurel <jonas.bjurel@ericsson.com>2015-01-30 22:22:43 +0100
committerJonas Bjurel <jonas.bjurel@ericsson.com>2015-02-05 19:39:31 +0100
commitd29df40fd66d6a90fde858e8a0bc0d0e98a01794 (patch)
tree17e48a2b5978b21c5a44ac0234626e8bb39c0af3 /fuel-build/patch-packages/python-nova
parent09247c2eca21891be5b04eda08a23d4a866a3b84 (diff)
Version 0.0.1 of /fuel-bild
This is a build system that rebases the result from fuel.org such that you can add or change packages/puppet manifests any way you like, and reliably produce a installable which can be reproduced any time. See README for more information. Signed-off-by: Jonas Bjurel <jonas.bjurel@ericsson.com>
Diffstat (limited to 'fuel-build/patch-packages/python-nova')
-rw-r--r--fuel-build/patch-packages/python-nova/Makefile29
-rw-r--r--fuel-build/patch-packages/python-nova/nova-console.patch17
2 files changed, 46 insertions, 0 deletions
diff --git a/fuel-build/patch-packages/python-nova/Makefile b/fuel-build/patch-packages/python-nova/Makefile
new file mode 100644
index 0000000..9bcff70
--- /dev/null
+++ b/fuel-build/patch-packages/python-nova/Makefile
@@ -0,0 +1,29 @@
+##############################################################################
+# Copyright (c) 2015 Ericsson AB and others.
+# stefan.k.berg@ericsson.com
+# jonas.bjurel@ericsson.com
+# All rights reserved. This program and the accompanying materials
+# are made available under the terms of the Apache License, Version 2.0
+# which accompanies this distribution, and is available at
+# http://www.apache.org/licenses/LICENSE-2.0
+##############################################################################
+
+TOP := $(shell pwd)
+
+.PHONY: all
+all:
+
+.PHONY: clean
+clean:
+ @rm -rf package
+ @rm -rf *.deb
+ @rm -rf patch-replacements
+ @rm -rf .package
+
+.PHONY: release
+release:
+ ../tools/deb_unpack python-nova_2014.1.3-fuel5.1.1~mira3_all.deb $(ORIGISO)
+ patch -s -p0 < nova-console.patch
+ ../tools/deb_pack $(VERSION)
+ @cp *.deb ../release/packages
+ @cat patch-replacements >> ../release/patch-replacements
diff --git a/fuel-build/patch-packages/python-nova/nova-console.patch b/fuel-build/patch-packages/python-nova/nova-console.patch
new file mode 100644
index 0000000..a05af3b
--- /dev/null
+++ b/fuel-build/patch-packages/python-nova/nova-console.patch
@@ -0,0 +1,17 @@
+--- package/usr/share/pyshared/nova/virt/libvirt/driver.py.org
++++ package/usr/share/pyshared/nova/virt/libvirt/driver.py
+@@ -3280,10 +3280,10 @@
+ # client app is connected. Thus we can't get away
+ # with a single type=pty console. Instead we have
+ # to configure two separate consoles.
+- consolelog = vconfig.LibvirtConfigGuestSerial()
+- consolelog.type = "file"
+- consolelog.source_path = self._get_console_log_path(instance)
+- guest.add_device(consolelog)
++ #consolelog = vconfig.LibvirtConfigGuestSerial()
++ #consolelog.type = "file"
++ #consolelog.source_path = self._get_console_log_path(instance)
++ #guest.add_device(consolelog)
+
+ consolepty = vconfig.LibvirtConfigGuestSerial()
+ consolepty.type = "pty"