summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMorgan Richomme <morgan.richomme@orange.com>2016-10-19 13:39:22 +0000
committerGerrit Code Review <gerrit@opnfv.org>2016-10-19 13:39:23 +0000
commit81029a5ad95469526166dbb114c86a3ab52d4c5f (patch)
tree2db232458411284c730ca9bab191c51a8ee1ade1 /setup.py
parentbcf9ace74a24c8f974b5aaa108fd85a918bb5fc9 (diff)
parent87ddf690c47d38659d9b126bb56aa7de18d22ef8 (diff)
Merge "Add unittests dir"
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py24
1 files changed, 24 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 000000000..58740f4aa
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,24 @@
+##############################################################################
+# All rights reserved. This program and the accompanying materials
+# are made available under the terms of the Apache License, Version 2.0
+# which accompanies this distribution, and is available at
+# http://www.apache.org/licenses/LICENSE-2.0
+##############################################################################
+
+from setuptools import setup, find_packages
+
+
+setup(
+ name="functest",
+ version="master",
+ packages=find_packages(),
+ include_package_data=True,
+ package_data={
+ },
+ url="https://www.opnfv.org",
+ install_requires=["coverage==4.1",
+ "mock==1.3.0",
+ "nose==1.3.7"],
+ entry_points={
+ }
+)