summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJose Lausuch <jose.lausuch@ericsson.com>2017-06-14 10:22:51 +0000
committerGerrit Code Review <gerrit@opnfv.org>2017-06-14 10:22:51 +0000
commit6049af70807987e124ba0cf4f05ee16fe89b88db (patch)
tree184641c1aec7d97a71ca2c6c61c2bef6f24dbfdd /setup.py
parentfb3ef61a03cdf2fb938d771e9d23f6435cff240f (diff)
parentff64d008bfea70efb1c8663adeb29ab175229732 (diff)
Merge "Update (test-)requirements.txt"
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py17
1 files changed, 12 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 460651cfd..a52d90555 100644
--- a/setup.py
+++ b/setup.py
@@ -9,9 +9,16 @@
# pylint: disable=missing-docstring
-from setuptools import setup
+import setuptools
-setup(
- setup_requires=['pbr>=1.9', 'setuptools>=17.1'],
- pbr=True,
-)
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
+setuptools.setup(
+ setup_requires=['pbr>=1.8'],
+ pbr=True)