diff options
author | Jose Lausuch <jose.lausuch@ericsson.com> | 2017-06-08 13:18:25 +0000 |
---|---|---|
committer | Gerrit Code Review <gerrit@opnfv.org> | 2017-06-08 13:18:25 +0000 |
commit | 7db24e2b6994487d225c150a20f3a91d7bf12588 (patch) | |
tree | 7998406aa3c8815b34089032d257fc844fdde4c9 /setup.py | |
parent | a48bf0c8306e566f15877f3bd72882cf8b7663db (diff) | |
parent | 53f6c3948e048fd8c639704a385f4beae01ebfd9 (diff) |
Merge "Leverage on pbr (Python Build Reasonableness)"
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 24 |
1 files changed, 8 insertions, 16 deletions
@@ -1,25 +1,17 @@ -############################################################################## +#!/usr/bin/env python + +# Copyright (c) 2017 Orange and others. +# # All rights reserved. This program and the accompanying materials # are made available under the terms of the Apache License, Version 2.0 # which accompanies this distribution, and is available at # http://www.apache.org/licenses/LICENSE-2.0 -############################################################################## -from setuptools import setup, find_packages +# pylint: disable=missing-docstring +from setuptools import setup setup( - name="functest", - version="master", - py_modules=['cli_base'], - packages=find_packages(), - include_package_data=True, - package_data={ - }, - url="https://www.opnfv.org", - entry_points={ - 'console_scripts': [ - 'functest=functest.cli.cli_base:cli' - ], - }, + setup_requires=['pbr>=1.9', 'setuptools>=17.1'], + pbr=True, ) |