summaryrefslogtreecommitdiffstats
path: root/fuel/build/patch-packages/novnc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'fuel/build/patch-packages/novnc/Makefile')
-rw-r--r--fuel/build/patch-packages/novnc/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/fuel/build/patch-packages/novnc/Makefile b/fuel/build/patch-packages/novnc/Makefile
new file mode 100644
index 000000000..16c0196e9
--- /dev/null
+++ b/fuel/build/patch-packages/novnc/Makefile
@@ -0,0 +1,22 @@
+# This is a temporary patch which add missing files
+# inside novnc ubuntu package.
+# Related bug: https://bugs.launchpad.net/fuel/+bug/1433894
+TOP := $(shell pwd)
+
+.PHONY: all
+all:
+
+.PHONY: clean
+clean:
+ @rm -rf package
+ @rm -rf *.deb
+ @rm -rf patch-replacements
+ @rm -rf .package
+
+.PHONY: release
+release:
+ ../tools/deb_unpack novnc_0.5.1*.deb $(ORIGISO)
+ ./fix-missing.sh
+ ../tools/deb_pack $(REVSTATE)
+ @cp *.deb ../release/packages
+ @cat patch-replacements >> ../release/patch-replacements