summaryrefslogtreecommitdiffstats
path: root/fuel/build/patch-packages/neutron-common
diff options
context:
space:
mode:
Diffstat (limited to 'fuel/build/patch-packages/neutron-common')
-rw-r--r--fuel/build/patch-packages/neutron-common/Makefile19
-rw-r--r--fuel/build/patch-packages/neutron-common/quota.patch67
2 files changed, 86 insertions, 0 deletions
diff --git a/fuel/build/patch-packages/neutron-common/Makefile b/fuel/build/patch-packages/neutron-common/Makefile
new file mode 100644
index 000000000..e9d43a4c0
--- /dev/null
+++ b/fuel/build/patch-packages/neutron-common/Makefile
@@ -0,0 +1,19 @@
+TOP := $(shell pwd)
+
+.PHONY: all
+all:
+
+.PHONY: clean
+clean:
+ @rm -rf package
+ @rm -rf *.deb
+ @rm -rf patch-replacements
+ @rm -rf .package
+
+.PHONY: release
+release:
+ ../tools/deb_unpack neutron-common_*.deb $(ORIGISO)
+ patch -s -p0 < quota.patch
+ ../tools/deb_pack $(REVSTATE)
+ @cp *.deb ../release/packages
+ @cat patch-replacements >> ../release/patch-replacements
diff --git a/fuel/build/patch-packages/neutron-common/quota.patch b/fuel/build/patch-packages/neutron-common/quota.patch
new file mode 100644
index 000000000..6f179f0ab
--- /dev/null
+++ b/fuel/build/patch-packages/neutron-common/quota.patch
@@ -0,0 +1,67 @@
+*** package/etc/neutron/neutron.conf.orig 2015-05-25 15:50:09.933131041 +0200
+--- package/etc/neutron/neutron.conf 2015-05-25 15:55:07.859210010 +0200
+***************
+*** 502,518 ****
+ # default_quota = -1
+
+ # Number of networks allowed per tenant. A negative value means unlimited.
+! # quota_network = 10
+
+ # Number of subnets allowed per tenant. A negative value means unlimited.
+! # quota_subnet = 10
+
+ # Number of ports allowed per tenant. A negative value means unlimited.
+ # quota_port = 50
+
+ # Number of security groups allowed per tenant. A negative value means
+ # unlimited.
+! # quota_security_group = 10
+
+ # Number of security group rules allowed per tenant. A negative value means
+ # unlimited.
+--- 502,521 ----
+ # default_quota = -1
+
+ # Number of networks allowed per tenant. A negative value means unlimited.
+! # This quota modified by OPNFV: 10 -> 50
+! quota_network = 50
+
+ # Number of subnets allowed per tenant. A negative value means unlimited.
+! # This quota modified by OPNFV: 10 -> 50
+! quota_subnet = 50
+
+ # Number of ports allowed per tenant. A negative value means unlimited.
+ # quota_port = 50
+
+ # Number of security groups allowed per tenant. A negative value means
+ # unlimited.
+! # This quota modified by OPNFV: 10 -> 50
+! quota_security_group = 50
+
+ # Number of security group rules allowed per tenant. A negative value means
+ # unlimited.
+***************
+*** 538,547 ****
+ # quota_health_monitor = -1
+
+ # Number of routers allowed per tenant. A negative value means unlimited.
+! # quota_router = 10
+
+ # Number of floating IPs allowed per tenant. A negative value means unlimited.
+! # quota_floatingip = 50
+
+ # Number of firewalls allowed per tenant. A negative value means unlimited.
+ # quota_firewall = 1
+--- 541,552 ----
+ # quota_health_monitor = -1
+
+ # Number of routers allowed per tenant. A negative value means unlimited.
+! # This quota modified by OPNFV: 10 -> 50
+! quota_router = 50
+
+ # Number of floating IPs allowed per tenant. A negative value means unlimited.
+! # This quota modified by OPNFV: 50 -> 100
+! quota_floatingip = 100
+
+ # Number of firewalls allowed per tenant. A negative value means unlimited.
+ # quota_firewall = 1