summaryrefslogtreecommitdiffstats
path: root/fuel/build/patch-packages/neutron-common/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'fuel/build/patch-packages/neutron-common/Makefile')
-rw-r--r--fuel/build/patch-packages/neutron-common/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/fuel/build/patch-packages/neutron-common/Makefile b/fuel/build/patch-packages/neutron-common/Makefile
new file mode 100644
index 000000000..e9d43a4c0
--- /dev/null
+++ b/fuel/build/patch-packages/neutron-common/Makefile
@@ -0,0 +1,19 @@
+TOP := $(shell pwd)
+
+.PHONY: all
+all:
+
+.PHONY: clean
+clean:
+ @rm -rf package
+ @rm -rf *.deb
+ @rm -rf patch-replacements
+ @rm -rf .package
+
+.PHONY: release
+release:
+ ../tools/deb_unpack neutron-common_*.deb $(ORIGISO)
+ patch -s -p0 < quota.patch
+ ../tools/deb_pack $(REVSTATE)
+ @cp *.deb ../release/packages
+ @cat patch-replacements >> ../release/patch-replacements