aboutsummaryrefslogtreecommitdiffstats
path: root/build/patch-packages/cirros_testvm
diff options
context:
space:
mode:
authorJonas Bjurel <jonas.bjurel@ericsson.com>2016-10-27 12:38:02 +0000
committerGerrit Code Review <gerrit@opnfv.org>2016-10-27 12:38:02 +0000
commit0799bce0ce6fb46cbf1c5a2d3b505627d963428a (patch)
tree7a070959b180a23566af0fb6b891b869327397ea /build/patch-packages/cirros_testvm
parentf7a740476332fffca2bea98dadb2ab454154bb6b (diff)
parente37746b93c622ddddeb44bc5791c8da4a98fff7f (diff)
Merge "Update cirros image"
Diffstat (limited to 'build/patch-packages/cirros_testvm')
-rw-r--r--build/patch-packages/cirros_testvm/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/build/patch-packages/cirros_testvm/Makefile b/build/patch-packages/cirros_testvm/Makefile
new file mode 100644
index 000000000..4cbe13f6c
--- /dev/null
+++ b/build/patch-packages/cirros_testvm/Makefile
@@ -0,0 +1,31 @@
+##############################################################################
+# Copyright (c) 2015,2016 Ericsson AB, Mirantis Inc. and others.
+# stefan.k.berg@ericsson.com
+# jonas.bjurel@ericsson.com
+# mpolenchuk@mirantis.com
+# All rights reserved. This program and the accompanying materials
+# are made available under the terms of the Apache License, Version 2.0
+# which accompanies this distribution, and is available at
+# http://www.apache.org/licenses/LICENSE-2.0
+##############################################################################
+
+TOP := $(shell pwd)
+
+.PHONY: all
+all:
+
+.PHONY: clean
+clean:
+ @rm -rf package
+ @rm -rf *.deb
+ @rm -rf patch-replacements
+ @rm -rf .package
+
+.PHONY: release
+release:
+ ../tools/deb_unpack c/cirros-testvm/cirros-testvm_0.3.4-2~u14.04+mos5_amd64.deb $(ORIGISO)
+ @rm -rf package/usr/share/cirros-testvm/*
+ wget -O package/usr/share/cirros-testvm/cirros-x86_64-disk.img http://download.cirros-cloud.net/daily/20160722/cirros-d160722-x86_64-disk.img
+ ../tools/deb_pack $(REVSTATE)
+ @cp *.deb ../release/packages
+ @cat patch-replacements >> ../release/patch-replacements