summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorTomi Juvonen <tomi.juvonen@nokia.com>2017-09-05 12:07:27 +0000
committerGerrit Code Review <gerrit@opnfv.org>2017-09-05 12:07:27 +0000
commit7cbdc3b64449c729c39dd33e1785076b8a127d68 (patch)
tree7577633af85bddabc17e965633a556dcdb4b6f9a /setup.py
parent1c1d3d1ddc21ae28deabef9f5f6e310d46fdf0ef (diff)
parent9ee9b136ebec5d21f5165acc5e4441c3e91a56dd (diff)
Merge "Add doctor-test package"
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py22
1 files changed, 22 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 00000000..a1e9b3bb
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,22 @@
+#!/usr/bin/env python
+
+# Copyright (c) 2017 Orange and others.
+#
+# All rights reserved. This program and the accompanying materials
+# are made available under the terms of the Apache License, Version 2.0
+# which accompanies this distribution, and is available at
+# http://www.apache.org/licenses/LICENSE-2.0
+
+import setuptools
+
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
+setuptools.setup(
+ setup_requires=['pbr>=1.8'],
+ pbr=True)