aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorCédric Ollivier <cedric.ollivier@orange.com>2020-03-19 09:33:51 +0100
committerCédric Ollivier <cedric.ollivier@orange.com>2020-03-20 10:31:06 +0100
commit576da4494f47260a3e3a30d4361e8ce410771d38 (patch)
tree182ce858c3d00501f3c7d8daab9ae01025ebce86 /setup.py
parent12c9651ae71ab27287d1fe27e625087e6008f9a0 (diff)
Create CIRV python package
It adds missing __init__py and fixes concrete and abstract dependencies. It adds pylint in tox without loading pylintrc which seems too much permissive. The missing requirements and the pylint fixes will be managed in next changes. Signed-off-by: Cédric Ollivier <cedric.ollivier@orange.com> Change-Id: Id4e1e290012e53e275f7d64765d388118e7ac235
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py29
1 files changed, 29 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..566d844
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,29 @@
+# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
+import setuptools
+
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
+setuptools.setup(
+ setup_requires=['pbr>=2.0.0'],
+ pbr=True)