diff options
author | 2017-02-07 15:29:50 +0800 | |
---|---|---|
committer | 2017-02-09 05:10:52 +0000 | |
commit | 0a29e9ec59e21dc46db0497187cc9d0de0844b05 (patch) | |
tree | 5222fd128df289fa3f6e56621c1a8af273e1eab3 /setup.py | |
parent | fd7583e843493495e5e15f62b5f7d9ca484bf167 (diff) |
Log_dir bug fix&Add function of test_ip init
JIRA:BOTTLENECK-129
This patch fix the error of log_dir can't be found.
And change several thing:
1.Add if config don't have test_ip, it will use local:8888 as test ip.
2.Fix the bug in setup.py.
3.Add parser init to logger file.
Change-Id: I808c69e2b2ff3c04f271cc7f3e14e1ab406a4d1b
Signed-off-by: liyin <liyin11@huawei.com>
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 60 |
1 files changed, 31 insertions, 29 deletions
@@ -7,38 +7,40 @@ # which accompanies this distribution, and is available at # http://www.apache.org/licenses/LICENSE-2.0 ############################################################################## -'''This file realize the function of how to setup bottlenecks to your environment -This use setuptools tool to setup''' +'''This file realize the function of how to setup bottlenecks +to your environment. This use setuptools tool to setup''' from setuptools import setup, find_packages setup( - name="bottlenecks", - version="master", - py_modules=['bottlenecks_cli'], - packages=find_packages(), - include_package_data=True, - package_data={ - 'utils': [ - 'utils/infra_setup/heat/*.py', - 'utils/infra_setup/runner/*.py' - ], - 'config': [ - '*.yaml' - ], - 'testsuites': [ - 'posca/testcase_cfg/*', - 'posca/testcase_script/*', - 'posca/testsuite_story/*', - 'posca/testcase_dashboard/*' - ], - }, - url="https://www.opnfv.org", - install_requires=["click"], - entry_points={ - 'console_scripts': [ - 'bottlenecks=cli.bottlenecks_cli:main' - ], - }, + name="bottlenecks", + version="master", + py_modules=['bottlenecks_cli'], + packages=find_packages(), + include_package_data=True, + package_data={ + 'utils': [ + 'utils/infra_setup/heat/*.py', + 'utils/infra_setup/runner/*.py', + 'utils/*.py' + ], + 'config': [ + '*.yaml' + ], + 'testsuites': [ + 'posca/testcase_cfg/*', + 'posca/testcase_script/*', + 'posca/testsuite_story/*', + 'posca/testcase_dashboard/*' + ], + }, + url="https://www.opnfv.org", + install_requires=["click"], + entry_points={ + 'console_scripts': [ + 'bottlenecks=cli.bottlenecks_cli:main' + ], + }, ) + |