summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorHarry Huang <huangxiangyu5@huawei.com>2018-01-18 20:43:47 +0800
committerHarry Huang <huangxiangyu5@huawei.com>2018-03-07 15:42:08 +0800
commit3e75ab6f1480659d6e12ddbfe3ae86fe2622d6d8 (patch)
tree2d5a17c1e73ba7def1f72c55a644b17cec80e90a /setup.py
parent3d636def30cd293231e84a7f2ecf7db2dfad334d (diff)
Add scripts to setup ONAP on OpenStack
JIRA: Auto-5 Setup ONAP environment on OpenStack. Develop Using Python considering its proved performence within OPNFV testing project, and with its rich library we can operate REST calls and json parsing in a more elegant way, also others can reuse the existing module to develop use cases and test cases. Main workflow: 1. prepare OpenStack to launch ONAP (images, security rules, keypair, etc) 2. launch ONAP stack Change-Id: Id99affccbcaa86be134a535f89b26c54ad137e21 Signed-off-by: Harry Huang <huangxiangyu5@huawei.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py28
1 files changed, 28 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..c7ec804
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,28 @@
+#!/usr/bin/env python
+########################################################################
+# Copyright (c) 2018 Huawei Technologies Co.,Ltd and others.
+#
+# All rights reserved. This program and the accompanying materials
+# are made available under the terms of the Apache License, Version 2.0
+# which accompanies this distribution, and is available at
+# http://www.apache.org/licenses/LICENSE-2.0
+########################################################################
+
+import os
+from setuptools import setup, find_packages
+
+__author__ = "Harry Huang <huangxiangyu5@huawei.com>"
+
+
+requirement_path = os.path.join(
+ os.path.dirname(__file__), 'requirements.txt')
+with open(requirement_path, 'r') as fd:
+ requirements = [line.strip() for line in fd if line != '\n']
+
+setup(
+ name="auto",
+ version='1.0.0',
+ packages=find_packages(),
+ include_package_data=True,
+ install_requires=requirements
+)