aboutsummaryrefslogtreecommitdiffstats
path: root/patches/opnfv-fuel/0025-f_repobuild-Makefile-Use-python-debian-from-pip.patch
diff options
context:
space:
mode:
authorAlexandru Avadanii <Alexandru.Avadanii@enea.com>2016-05-31 22:34:54 +0200
committerAlexandru Avadanii <Alexandru.Avadanii@enea.com>2016-06-04 16:04:52 +0000
commite7e2d84bec0d404057bce203f9c90231360e88ee (patch)
tree43e54e897217da67906580991c3c7f0a110250e8 /patches/opnfv-fuel/0025-f_repobuild-Makefile-Use-python-debian-from-pip.patch
parent70f2caa773fc5f0e2b1154a5c095665375f02666 (diff)
Rebase: deploy related patch series.
After change "common.py: catch stderr in exec_cmd" [1] and other unrelated changes were merged upstream, we need to rebase the complete deploy related series. While we're at it, re-export Fuel@OPNFV patches in Armband. [1] https://gerrit.opnfv.org/gerrit/#/c/14561/ Change-Id: Icbc8261c2e24e4b29e8f5f2bc83db6829219129a
Diffstat (limited to 'patches/opnfv-fuel/0025-f_repobuild-Makefile-Use-python-debian-from-pip.patch')
-rw-r--r--patches/opnfv-fuel/0025-f_repobuild-Makefile-Use-python-debian-from-pip.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/patches/opnfv-fuel/0025-f_repobuild-Makefile-Use-python-debian-from-pip.patch b/patches/opnfv-fuel/0025-f_repobuild-Makefile-Use-python-debian-from-pip.patch
new file mode 100644
index 00000000..f84b4c0c
--- /dev/null
+++ b/patches/opnfv-fuel/0025-f_repobuild-Makefile-Use-python-debian-from-pip.patch
@@ -0,0 +1,29 @@
+From: Alexandru Avadanii <Alexandru.Avadanii@enea.com>
+Date: Tue, 26 Apr 2016 23:12:20 +0200
+Subject: [PATCH] f_repobuild/Makefile: Use python-debian from pip.
+
+Currently, Ubuntu Trusty provides a broken python-debian package,
+that fails to parse foreign architecture (package:any) relationships.
+
+Purge debian package and let pip resolve this dependency, using a
+newer version from pypi.
+
+[1] http://lists.alioth.debian.org/pipermail/
+ pkg-python-debian-maint/2014-July/001795.html
+---
+ build/f_isoroot/f_repobuild/Makefile | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/build/f_isoroot/f_repobuild/Makefile b/build/f_isoroot/f_repobuild/Makefile
+index 709ca6b..5e7157b 100644
+--- a/build/f_isoroot/f_repobuild/Makefile
++++ b/build/f_isoroot/f_repobuild/Makefile
+@@ -25,6 +25,8 @@ all: nailgun
+
+ nailgun:
+ sudo apt-get install -y git libxml2-dev libxslt-dev python-dev python-pip libz-dev libyaml-dev createrepo python-yaml
++ # python-debian from Ubuntu can't parse foreign arch relationships, use pip
++ sudo apt-get purge -y --force-yes python-debian
+ rm -Rf nailgun
+ sudo mkdir -p /var/www/nailgun
+ git clone $(FUEL_MIRROR_REPO)