summaryrefslogtreecommitdiffstats
path: root/build/rpm_specs/zrpc.spec
diff options
context:
space:
mode:
authorTim Rozet <trozet@redhat.com>2017-02-18 12:52:54 +0000
committerGerrit Code Review <gerrit@opnfv.org>2017-02-18 12:52:54 +0000
commit645949cbac2bb766d18dfd9f818b6c14545a35e2 (patch)
treeb263d9883e49ec162b6aa86ae7204b151e17a0c4 /build/rpm_specs/zrpc.spec
parent89f0410672d80015c419f77e69a5bb155cac2bfe (diff)
parenta7155293dba7c21f060b671b15fc36a66b84de83 (diff)
Merge "Adding Quagga to build"
Diffstat (limited to 'build/rpm_specs/zrpc.spec')
-rw-r--r--build/rpm_specs/zrpc.spec46
1 files changed, 46 insertions, 0 deletions
diff --git a/build/rpm_specs/zrpc.spec b/build/rpm_specs/zrpc.spec
new file mode 100644
index 00000000..a8dd3b75
--- /dev/null
+++ b/build/rpm_specs/zrpc.spec
@@ -0,0 +1,46 @@
+Name: zrpcd
+Version: 0.2
+Release: 0
+
+Summary: Zebra Remote Procedure Call
+Group: Applications/Internet
+License: GPL
+Source0: %{name}-%{version}.tar.gz
+Source1: zrpcd.service
+
+BuildRequires: systemd-units
+
+Requires: thrift zeromq glib2 c-capnproto capnproto quagga
+Requires(post): systemd
+Requires(preun): systemd
+Requires(postun): systemd
+%description
+ZRPC provides a Thrift API and handles RPC to configure Quagga framework.
+
+%prep
+%setup -q
+
+%build
+
+%configure
+
+%install
+mkdir -p %{buildroot}%{_unitdir}
+install -p -D -m 644 %{SOURCE1} %{buildroot}%{_unitdir}/zrpcd.service
+%make_install
+
+%post
+%systemd_post zrpcd.service
+
+%preun
+%systemd_preun zrpcd.service
+
+%postun
+%systemd_postun_with_restart zrpcd.service
+
+%files
+%defattr(-,root,root)
+%{_sbindir}/zrpcd
+%{_includedir}/%name/zrpc_global.h
+%{_includedir}/%name/zrpc_os_wrapper.h
+%{_unitdir}/zrpcd.service