summaryrefslogtreecommitdiffstats
path: root/build/opnfv-apex-common.spec
diff options
context:
space:
mode:
authorTim Rozet <trozet@redhat.com>2016-04-11 14:22:27 -0400
committerDan Radez <dradez@redhat.com>2016-04-19 13:14:38 -0400
commit92e4b9310b8582bcd751ce0f8fe3fab98d195d71 (patch)
tree8e45801af0a170213cc9adb7e5451a297acd1b55 /build/opnfv-apex-common.spec
parent9c61a258f48ab463bde4b06045b49a64de1d6336 (diff)
Adds Utility functions and failure logging
Patch adds helpful utility functions and automatic parsing of heat output into a readable format indicating where a failure is in a deployment. Example: http://fpaste.org/354210/ New opnfv-util function allows a user to interact with a deployment easily: - opnfv-util undercloud <user> connects user to undercloud VM - opnfv-util debug-stack parses the heat failure output Above arguments also accept partial matches. JIRA: APEX-75 Change-Id: I5ccfee64ee2958de0d00a3b25cd9b29de60c9e20 Signed-off-by: Tim Rozet <trozet@redhat.com> (cherry picked from commit 0717bc3c56ab294f860ef99116754c1fd786cae7)
Diffstat (limited to 'build/opnfv-apex-common.spec')
-rw-r--r--build/opnfv-apex-common.spec6
1 files changed, 6 insertions, 0 deletions
diff --git a/build/opnfv-apex-common.spec b/build/opnfv-apex-common.spec
index b195ddb2..0a80f521 100644
--- a/build/opnfv-apex-common.spec
+++ b/build/opnfv-apex-common.spec
@@ -28,6 +28,7 @@ rst2html docs/release-notes/release-notes.rst docs/release-notes.html
mkdir -p %{buildroot}%{_bindir}/
install ci/deploy.sh %{buildroot}%{_bindir}/opnfv-deploy
install ci/clean.sh %{buildroot}%{_bindir}/opnfv-clean
+install ci/util.sh %{buildroot}%{_bindir}/opnfv-util
mkdir -p %{buildroot}%{_sysconfdir}/opnfv-apex/
install config/deploy/os-nosdn-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
@@ -41,6 +42,7 @@ install config/deploy/network/network_settings.yaml %{buildroot}%{_sysconfdir}/o
mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/
install lib/common-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
+install lib/utility-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
install lib/installer/onos/onos_gw_mac_update.sh %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
@@ -57,7 +59,9 @@ install config/inventory/pod_example_settings.yaml %{buildroot}%{_docdir}/opnfv/
%defattr(644, root, root, -)
%attr(755,root,root) %{_bindir}/opnfv-deploy
%attr(755,root,root) %{_bindir}/opnfv-clean
+%attr(755,root,root) %{_bindir}/opnfv-util
%{_var}/opt/opnfv/lib/common-functions.sh
+%{_var}/opt/opnfv/lib/utility-functions.sh
%{_var}/opt/opnfv/lib/installer/onos/onos_gw_mac_update.sh
%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
%{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
@@ -76,6 +80,8 @@ install config/inventory/pod_example_settings.yaml %{buildroot}%{_docdir}/opnfv/
%doc %{_docdir}/opnfv/inventory.yaml.example
%changelog
+* Mon Apr 11 2016 Tim Rozet <trozet@redhat.com> - 2.2-1
+- adding opnfv-util
* Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 2.2-0
- Brahmaputra SR1
- adding dependencies initscripts net-tools iputils iproute iptables