diff options
author | 2017-01-10 18:45:51 +0000 | |
---|---|---|
committer | 2017-01-10 18:45:51 +0000 | |
commit | 40561a3ad33c56e594908374f1d130a641294c5f (patch) | |
tree | ddae41d59c6c3b17cf83d304f8b9f4d4fd3c77ab /setup.py | |
parent | b23483ee058f7e6acc481d53664580634417f8b8 (diff) | |
parent | 216aa0d4dbe24e49414e1cff7d565963dfee73b3 (diff) |
Merge "Updated from global requirements"
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 11 |
1 files changed, 9 insertions, 2 deletions
@@ -1,4 +1,3 @@ -#!/usr/bin/env python # Copyright (c) 2013 Hewlett-Packard Development Company, L.P. # # Licensed under the Apache License, Version 2.0 (the "License"); @@ -17,6 +16,14 @@ # THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT import setuptools +# In python < 2.7.4, a lazy loading of package `pbr` will break +# setuptools if some other modules registered functions in `atexit`. +# solution from: http://bugs.python.org/issue15881#msg170215 +try: + import multiprocessing # noqa +except ImportError: + pass + setuptools.setup( - setup_requires=['pbr'], + setup_requires=['pbr>=1.8'], pbr=True) |