diff options
author | 2017-03-31 17:44:38 +0000 | |
---|---|---|
committer | 2017-03-31 17:45:11 +0000 | |
commit | 8d8f96ac1a3d380adb943893eed22b1f9ae254d7 (patch) | |
tree | 18fba05e2007a3f81f7c1f149995f9bfbee1fd89 /setup.py | |
parent | 7a65a0de1f3598e11a77bc15b110193d253215ec (diff) |
Updated from global requirements
It appears os-net-config is not in the sync list for g-r. We should
add it, but in the meantime this will get us up to date.
Change-Id: I828a394ce72824eaabe904b563f73734a88c21f8
Diffstat (limited to 'setup.py')
-rw-r--r--[-rwxr-xr-x] | setup.py | 11 |
1 files changed, 9 insertions, 2 deletions
@@ -1,4 +1,3 @@ -#!/usr/bin/env python # Copyright (c) 2013 Hewlett-Packard Development Company, L.P. # # Licensed under the Apache License, Version 2.0 (the "License"); @@ -17,6 +16,14 @@ # THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT import setuptools +# In python < 2.7.4, a lazy loading of package `pbr` will break +# setuptools if some other modules registered functions in `atexit`. +# solution from: http://bugs.python.org/issue15881#msg170215 +try: + import multiprocessing # noqa +except ImportError: + pass + setuptools.setup( - setup_requires=['pbr'], + setup_requires=['pbr>=2.0.0'], pbr=True) |