summaryrefslogtreecommitdiffstats
path: root/xci/playbooks/roles/configure-network/templates/debian/controller00.interface.j2
diff options
context:
space:
mode:
Diffstat (limited to 'xci/playbooks/roles/configure-network/templates/debian/controller00.interface.j2')
-rw-r--r--xci/playbooks/roles/configure-network/templates/debian/controller00.interface.j28
1 files changed, 8 insertions, 0 deletions
diff --git a/xci/playbooks/roles/configure-network/templates/debian/controller00.interface.j2 b/xci/playbooks/roles/configure-network/templates/debian/controller00.interface.j2
index 5d42a5d2..b461b201 100644
--- a/xci/playbooks/roles/configure-network/templates/debian/controller00.interface.j2
+++ b/xci/playbooks/roles/configure-network/templates/debian/controller00.interface.j2
@@ -54,6 +54,14 @@ iface br-vlan inet static
netmask 255.255.255.0
gateway 192.168.122.1
dns-nameserver 8.8.8.8 8.8.4.4
+ # Create veth pair, don't bomb if already exists
+ pre-up ip link add br-vlan-veth type veth peer name eth12 || true
+ # Set both ends UP
+ pre-up ip link set br-vlan-veth up
+ pre-up ip link set eth12 up
+ # Delete veth pair on DOWN
+ post-down ip link del br-vlan-veth || true
+ bridge_ports br-vlan-veth
# OpenStack Storage bridge
auto br-storage