aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorCédric Ollivier <cedric.ollivier@orange.com>2019-06-13 16:50:01 +0200
committerCédric Ollivier <cedric.ollivier@orange.com>2019-07-17 20:32:12 +0200
commitf377ca166f1e0f81b685e3a76ef0287cdc011cd1 (patch)
tree01950a61457d2966d3974ef7544f39aef4f2202d /setup.py
parentd57f3eefc23b2bdcc7eb70b19e09cfd22fc36e25 (diff)
Leverage on PBR
It fixes requirements and constraints by switching to PBR [1]. It synchronizes requirements with OpenStack stable/stein and then adds constraints to pip calls. It also updates flask-restful-swagger to conform with OpenStack upper-constraints [2] and the pip API calls. It updates the unit tests verifying a few package versions. It stops checking unicodecsv in py3 env which is against the requirements defined in OpenStack. It also skips one test indirectly highlighting that the pip usage is incorrect [3] [1] http://testresults.opnfv.org/functest/dockerslicing/ [2] https://github.com/rantav/flask-restful-swagger/commit/fd418b50723fe1e79f495aa400a8e9f055a5be27 [3] https://github.com/pypa/pip/issues/3889 Change-Id: I635bdb9d7411e619cee911b633fa8ad591a393a0 Signed-off-by: Cédric Ollivier <cedric.ollivier@orange.com>
Diffstat (limited to 'setup.py')
-rw-r--r--[-rwxr-xr-x]setup.py87
1 files changed, 26 insertions, 61 deletions
diff --git a/setup.py b/setup.py
index cbf8b15c6..7fcba2b50 100755..100644
--- a/setup.py
+++ b/setup.py
@@ -1,64 +1,29 @@
-##############################################################################
-# Copyright (c) 2017 Ericsson AB and others.
+# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
#
-# All rights reserved. This program and the accompanying materials
-# are made available under the terms of the Apache License, Version 2.0
-# which accompanies this distribution, and is available at
-# http://www.apache.org/licenses/LICENSE-2.0
-##############################################################################
-from __future__ import absolute_import
-from setuptools import setup, find_packages
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
+import setuptools
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa # pylint:disable=unused-import
+except ImportError:
+ pass
-setup(
- name="yardstick",
- version="0.1.dev0",
- packages=find_packages(),
- include_package_data=True,
- package_data={
- 'yardstick': [
- 'benchmark/scenarios/availability/*.yaml',
- 'benchmark/scenarios/availability/attacker/*.yaml',
- 'benchmark/scenarios/availability/ha_tools/*.bash',
- 'benchmark/scenarios/availability/ha_tools/*/*.bash',
- 'benchmark/scenarios/availability/attacker/scripts/*.bash',
- 'benchmark/scenarios/availability/monitor/*.yaml',
- 'benchmark/scenarios/availability/monitor/script_tools/*.bash',
- 'benchmark/scenarios/compute/*.bash',
- 'benchmark/scenarios/networking/*.bash',
- 'benchmark/scenarios/networking/*.txt',
- 'benchmark/scenarios/parser/*.sh',
- 'benchmark/scenarios/storage/*.bash',
- 'network_services/nfvi/collectd.conf',
- 'network_services/nfvi/collectd.sh',
- 'resources/files/*',
- 'resources/scripts/install/*.bash',
- 'resources/scripts/remove/*.bash',
- 'resources/templates/*.vat'
- ],
- 'etc': [
- 'yardstick/nodes/*/*.yaml',
- 'yardstick/*.sample'
- ],
- 'tests': [
- 'opnfv/*/*.yaml',
- 'ci/*.sh'
- ]
- },
- url="https://www.opnfv.org",
- extras_require={
- 'plot': ["matplotlib>=1.4.2"]
- },
- entry_points={
- 'console_scripts': [
- 'yardstick=yardstick.main:main',
- 'yardstick-plot=yardstick.plot.plotter:main [plot]'
- ],
- 'yardstick.scenario': []
- },
- scripts=[
- 'tools/yardstick-img-modify',
- 'tools/yardstick-img-lxd-modify',
- 'tools/yardstick-img-dpdk-modify'
- ]
-)
+setuptools.setup(
+ setup_requires=['pbr>=2.0.0'],
+ pbr=True)