aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorkubi <jean.gaoliang@huawei.com>2015-12-29 11:04:20 +0800
committerkubi <jean.gaoliang@huawei.com>2016-01-09 13:10:02 +0800
commitd93f6ca5bf0d4f22ec0fd90eac1bf8b9c09db820 (patch)
tree840ebf964154f0c2925097a16a43ce07d60050d4 /setup.py
parent45b1cc64209dec07475e5263469328231c524aa7 (diff)
running Parser Yang-to-Tosca module as a tool
with jnon and fatih's help, new docker image has been uploaded so this part is about parser verify validating output against expected outcome. Change-Id: If50d241a5338888f14fd11a752dc72678e0c569b JIRA:YARDSTICK-224 Signed-off-by: kubi <jean.gaoliang@huawei.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 872760ae5..e923b23c5 100755
--- a/setup.py
+++ b/setup.py
@@ -13,6 +13,7 @@ setup(
'benchmark/scenarios/compute/*.bash',
'benchmark/scenarios/networking/*.bash',
'benchmark/scenarios/networking/*.txt',
+ 'benchmark/scenarios/parser/*.sh',
'benchmark/scenarios/storage/*.bash',
'resources/files/*'
]
@@ -22,6 +23,7 @@ setup(
"coverage>=3.6",
"flake8",
"Jinja2>=2.6",
+ "lxml",
"PyYAML>=3.10",
"pbr<2.0,>=1.3",
"python-glanceclient>=0.12.0",