aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJo¶rgen Karlsson <jorgen.w.karlsson@ericsson.com>2016-03-11 12:54:22 +0100
committerJörgen Karlsson <jorgen.w.karlsson@ericsson.com>2016-03-15 14:32:00 +0000
commitbce1f77ef610e3e7997a547704c96cfbdc544cc1 (patch)
tree62d7e63ca58c53bdabe429e90ebdf339fadc0b6b /setup.py
parent6a4bd2c4bdce07b945ab61e1151e67da99be7489 (diff)
Update setup.py and dependencies
Fixes dependency problem with python-openstackclient Freezes requirements to use latest/current upstream versions Yardstick can be installed with: $ python setup.py install or with: $ easy_install -U pip $ pip install -r ci/requirements.txt $ pip install . (or for develop mode: pip install -e .) if fixed package versions are required Change-Id: I9cb44d29011509c9c388dc2e7dc8bb60ee25e790 JIRA:- Signed-off-by: Jo¶rgen Karlsson <jorgen.w.karlsson@ericsson.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 6df0e17f2..31d23de3a 100755
--- a/setup.py
+++ b/setup.py
@@ -28,7 +28,7 @@ setup(
"lxml",
"PyYAML>=3.10",
"pbr<2.0,>=1.3",
- "python-openstackclient<=2.0.0",
+ "python-openstackclient>=2.1.0",
"python-glanceclient>=0.12.0",
"python-heatclient>=0.2.12",
"python-keystoneclient>=0.11.1",