aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorRodolfo Alonso Hernandez <rodolfo.alonso.hernandez@intel.com>2018-01-23 16:23:57 +0000
committerRodolfo Alonso Hernandez <rodolfo.alonso.hernandez@intel.com>2018-01-30 10:13:40 +0000
commit352478d837893167b90d321e22f276ce65f7ce43 (patch)
tree6f7c91b5f78871c4b509eeeba183682967e98fca /setup.py
parentfa6a71d6a0f654d9e85a6dd8f73c1173f75ccdde (diff)
Make 'Scenario' classes plugable
This patch makes yardstick.benchmark.scenario.base:Scenario classes plugable. A new entry point is added to the setup. This entry point could be extended in other plugin projects to add new Scenario classes. E.g.: take a look at [1]. This is a Yardstick plugin example project. Clone the project and execute, from the project directory: $ sudo -EH python setup.py install This will add a new module to python ('yardstick-new-plugin') and a new Scenario class. Now list the scenarios in Yardstick: $ yardstick scenario list ... | SpecCPU2006_for_VM | Spec CPU2006 benchmark for Virtual Machine | | SpecCPU2006 | Spec CPU2006 benchmark | | Dummy2 | Execute Dummy (v2!) echo | +-----------------------+--------------------------------------------+ [1] https://github.com/ralonsoh/yardstick_new_plugin JIRA: YARDSTICK-910 Change-Id: Ib70ee9bf4dc7ff91d1dd6377317b313288e36bff Signed-off-by: Rodolfo Alonso Hernandez <rodolfo.alonso.hernandez@intel.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 7f6571d61..881ef9272 100755
--- a/setup.py
+++ b/setup.py
@@ -53,6 +53,7 @@ setup(
'yardstick=yardstick.main:main',
'yardstick-plot=yardstick.plot.plotter:main [plot]'
],
+ 'yardstick.scenario': []
},
scripts=[
'tools/yardstick-img-modify',