aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorHans Feldt <hans.feldt@ericsson.com>2015-05-12 18:25:42 +0200
committerHans Feldt <hans.feldt@ericsson.com>2015-05-13 09:31:04 +0000
commit2d131cd335b35914133d3dd8d1d8f5741fc38eb0 (patch)
tree6c891c459a58d5c2625aea2b3b71f16128f36244 /setup.py
parent6c8042ae1c057b701d1c42a563faab4b216d4d92 (diff)
add README and scripts for build and test
README.rst is work in progress and probably not proper rst format yet but should still contain valuable information. run_tests.sh is a script that runs unit and style tests on the code. It can be used as a gate check in gerrit. Similar scripts are standard practice in other open source projects. JIRA: - Change-Id: I5e586b346ff45f1151960a0e7fda2fe6072422c0 Signed-off-by: Hans Feldt <hans.feldt@ericsson.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py24
1 files changed, 24 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 000000000..8c16c56ea
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,24 @@
+import ez_setup
+from setuptools import setup, find_packages
+
+ez_setup.use_setuptools()
+
+setup(
+ name="yardstick",
+ version="0.1dev",
+ packages=find_packages(),
+ scripts=['bin/yardstick'],
+ include_package_data=True,
+ url="https://www.opnfv.org",
+ install_requires=["flake8",
+ "PyYAML>=3.10",
+ "python-glanceclient>=0.12.0",
+ "python-heatclient>=0.2.12",
+ "python-keystoneclient>=0.11.1",
+ "python-neutronclient>=2.3.9",
+ "python-novaclient>=2.24.1",
+ "mock>=1.0.1",
+ "paramiko",
+ "six"
+ ],
+)