aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorKristian Hunt <kristian.hunt@gmail.com>2015-07-15 10:43:09 +0200
committerJörgen Karlsson <jorgen.w.karlsson@ericsson.com>2015-08-14 09:14:23 +0000
commit1747afd41c228bd5bff17c5233ded5061791363e (patch)
tree4cd821e24575f33a1dc626f25e5219ebbc3fed9c /setup.py
parenteca1e81cac34d7569fa5dcb15e5df10a6583559b (diff)
Add support for generating graphs from output
Command line tool yardstick-plot is to be used to visualize results gathered from yardstick framework's output file. Currently supports plotting graphs from ping, pktgen, iperf3 and fio tests. Yardstick-plot takes two arguments - input file and output folder and both of them have defaults to fall to if left unspecified. Supports having multiple different scenario types in an input file, while assuming that all results from the same scenario type belong to one graph. Thus, results plotted from a single scenario type with different parameters are currently non-informative. yardstick-plot is declared as an extra for yardstick in setup.py as it is not required for all use cases of the yardstick framework. It can be installed for example using command: $ pip install -e .[plot] from the folder where setup.py is located. Example invocation: yardstick-plot -i /tmp/yardstick.out -o /tmp/plots/ JIRA: YARDSTICK-65 Change-Id: Ic436ca360ba2496aa829ca817b1d9d5f3c944c6c Signed-off-by: Kristian Hunt <kristian.hunt@gmail.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index a346f5765..f73094ac1 100644
--- a/setup.py
+++ b/setup.py
@@ -14,7 +14,7 @@ setup(
'benchmark/scenarios/networking/*.bash',
'benchmark/scenarios/storage/*.bash',
'resources/files/*'
- ]
+ ]
},
url="https://www.opnfv.org",
install_requires=["backport_ipaddress", # remove with python3
@@ -30,9 +30,13 @@ setup(
"paramiko",
"six"
],
+ extras_require={
+ 'plot': ["matplotlib>=1.4.2"]
+ },
entry_points={
'console_scripts': [
'yardstick=yardstick.main:main',
+ 'yardstick-plot=yardstick.plot.plotter:main [plot]'
],
},
scripts=['tools/yardstick-img-modify']