aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorchenjiankun <chenjiankun1@huawei.com>2016-11-10 07:24:15 +0000
committerchenjiankun <chenjiankun1@huawei.com>2016-11-15 06:38:24 +0000
commit02e9da46ba3eed7e4552a30030000459fb56b7da (patch)
tree502e62cb237c3d36fd14698c2d6ecb5ad670fd7a /setup.py
parent492f64b990e8487894f30f7cbce4cbff7e720d16 (diff)
Yardstick installation unified (pip/setup)
JIRA: YARDSTICK-394 Change-Id: I486aa24121b2ad8d66cd6df97ca86ef826862c91 Signed-off-by: chenjiankun <chenjiankun1@huawei.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py31
1 files changed, 5 insertions, 26 deletions
diff --git a/setup.py b/setup.py
index 9bf656bac..6a89d6368 100755
--- a/setup.py
+++ b/setup.py
@@ -32,28 +32,6 @@ setup(
]
},
url="https://www.opnfv.org",
- install_requires=["backport_ipaddress", # remove with python3
- "coverage>=3.6",
- "flake8",
- "Jinja2>=2.6",
- "lxml",
- "PyYAML>=3.10",
- "pbr<2.0,>=1.3",
- "python-openstackclient>=2.1.0",
- "python-glanceclient>=0.12.0",
- "python-heatclient>=0.2.12",
- "python-keystoneclient>=0.11.1",
- "python-neutronclient>=2.3.9",
- "python-novaclient>=2.24.1",
- "mock>=1.0.1", # remove with python3
- "paramiko",
- "netifaces",
- "scp",
- "six",
- "testrepository>=0.0.18",
- "testtools>=1.4.0",
- "nose"
- ],
extras_require={
'plot': ["matplotlib>=1.4.2"]
},
@@ -63,8 +41,9 @@ setup(
'yardstick-plot=yardstick.plot.plotter:main [plot]'
],
},
- scripts=['tools/yardstick-img-modify',
- 'tools/yardstick-img-lxd-modify',
- 'tools/yardstick-img-dpdk-modify'
- ]
+ scripts=[
+ 'tools/yardstick-img-modify',
+ 'tools/yardstick-img-lxd-modify',
+ 'tools/yardstick-img-dpdk-modify'
+ ]
)