summaryrefslogtreecommitdiffstats
path: root/src/ceph/doc/man/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/ceph/doc/man/CMakeLists.txt')
-rw-r--r--src/ceph/doc/man/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/ceph/doc/man/CMakeLists.txt b/src/ceph/doc/man/CMakeLists.txt
new file mode 100644
index 0000000..e81631b
--- /dev/null
+++ b/src/ceph/doc/man/CMakeLists.txt
@@ -0,0 +1,15 @@
+set(sphinx_input)
+set(sphinx_output)
+set(sphinx_output_dir ${CMAKE_BINARY_DIR}/doc/man)
+
+add_subdirectory(8)
+
+add_custom_command(
+ OUTPUT ${sphinx_output}
+ COMMAND ${SPHINX_BUILD} -b man -t man -d ${CMAKE_BINARY_DIR}/doc/doctrees -c ${CMAKE_SOURCE_DIR}/man ${CMAKE_CURRENT_SOURCE_DIR} ${sphinx_output_dir}
+ DEPENDS ${sphinx_input})
+
+add_custom_target(
+ manpages ALL
+ DEPENDS ${sphinx_output}
+ COMMENT "manpages building")