aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorCédric Ollivier <cedric.ollivier@orange.com>2017-06-24 10:36:17 +0200
committerCédric Ollivier <cedric.ollivier@orange.com>2017-06-26 15:08:45 +0200
commitbe6ec06f040e1c710a70d624eeb44ee4a65add9b (patch)
tree37b2c607d909a9874e5d2e9e0cefc62f5b2c8127 /setup.py
parenta29f1fcf91f130f74dbd9d7c83bb7445faec6136 (diff)
Add requirements in sfc
It now leverages on pbr to scan requirements.txt and inject them into the install_requires. Change-Id: If51827f6f8839af930c862d846b76b85a778c860 Signed-off-by: Cédric Ollivier <cedric.ollivier@orange.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py28
1 files changed, 15 insertions, 13 deletions
diff --git a/setup.py b/setup.py
index 07de7888..a1e9b3bb 100644
--- a/setup.py
+++ b/setup.py
@@ -1,20 +1,22 @@
-##############################################################################
+#!/usr/bin/env python
+
+# Copyright (c) 2017 Orange and others.
+#
# All rights reserved. This program and the accompanying materials
# are made available under the terms of the Apache License, Version 2.0
# which accompanies this distribution, and is available at
# http://www.apache.org/licenses/LICENSE-2.0
-##############################################################################
-
-from setuptools import setup, find_packages
+import setuptools
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
-setup(
- name="sfc",
- version="danube",
- packages=find_packages(),
- include_package_data=True,
- package_data={
- },
- url="https://www.opnfv.org"
-)
+setuptools.setup(
+ setup_requires=['pbr>=1.8'],
+ pbr=True)