summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorjose.lausuch <jose.lausuch@ericsson.com>2016-12-22 09:42:08 +0100
committerjose.lausuch <jose.lausuch@ericsson.com>2016-12-22 09:42:08 +0100
commit7bc4d663eae8441aad359966d33db62726b92710 (patch)
tree98da4dc2f5a8899a741d61b721635a5e4767e3e4 /setup.py
parent9d112e4b1a00063f79b088dab93d1700bfb9c0dd (diff)
Use find_packages when installing sdnvpn
If we specify only the module 'sdnvpn', it won't install the sub-modules 'lib' and 'functest'. With find_packages there is no need to specify the package names. Change-Id: If7606a2cedbd6f7b8866747e748eadaa8b9bd5e7 Signed-off-by: jose.lausuch <jose.lausuch@ericsson.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 6347eb8..a637260 100644
--- a/setup.py
+++ b/setup.py
@@ -6,13 +6,13 @@
##############################################################################
-from setuptools import setup
+from setuptools import setup, find_packages
setup(
name="sdnvpn",
version="danube",
- packages=['sdnvpn'],
+ packages=find_packages(),
include_package_data=True,
package_data={},
url="https://www.opnfv.org")