aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorlhinds <lhinds@redhat.com>2017-05-17 13:31:18 +0100
committerlhinds <lhinds@redhat.com>2017-05-22 14:12:27 +0100
commit0142c227fca974fb65561d0aeb9b38c8683e22e6 (patch)
treef802b60e2ceab8b033212568d3adddc754faa7da /setup.py
parent9c00ca00dcad5624288de38e0a529f7f7b3915db (diff)
Initial code push of Anteater
Likely far to much to cover in a commit msg. Main bulk is the Anteater code itself, alongside packaging requirements and build tools and Dockerfile. Unit tests are planned as a follow up, so pushing this for now so that efforts can get underway to integrate the tool with jjb. Questions on how it works, please reach me in IRC. Change-Id: I2cd3cae391f8bf2cdc91b39c56dfc4833a1c4913 Signed-off-by: lhinds <lhinds@redhat.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py79
1 files changed, 79 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..47d1b19
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,79 @@
+# -*- coding: utf-8 -*-
+import re
+import sys
+from setuptools.command.test import test as TestCommand
+from setuptools import setup, find_packages
+
+REQUIRES = [
+ 'docopt',
+]
+
+
+class PyTest(TestCommand):
+ def finalize_options(self):
+ TestCommand.finalize_options(self)
+ self.test_args = []
+ self.test_suite = True
+
+ def run_tests(self):
+ import pytest
+ errcode = pytest.main(self.test_args)
+ sys.exit(errcode)
+
+
+def find_version(fname):
+ '''Attempts to find the version number in the file names fname.
+ Raises RuntimeError if not found.
+ '''
+ version = ''
+ with open(fname, 'r') as fp:
+ reg = re.compile(r'__version__ = [\'"]([^\'"]*)[\'"]')
+ for line in fp:
+ m = reg.match(line)
+ if m:
+ version = m.group(1)
+ break
+ if not version:
+ raise RuntimeError('Cannot find version information')
+ return version
+
+__version__ = find_version("anteater/anteater.py")
+
+
+def read(fname):
+ with open(fname) as fp:
+ content = fp.read()
+ return content
+
+setup(
+ name='anteater',
+ version="0.1",
+ description='anteater',
+ long_description=read("README.md"),
+ author='Luke Hinds',
+ author_email='lhinds@redhat.com',
+ url='https://gerrit.opnfv.org/gerrit/gitweb?p=releng-anteater.git',
+ install_requires=REQUIRES,
+ license=read("LICENSE"),
+ zip_safe=False,
+ keywords='anteater',
+ classifiers=[
+ 'Development Status :: 2 - Pre-Alpha',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: Apache Software License',
+ 'Natural Language :: English',
+ "Programming Language :: Python :: 2",
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ 'Programming Language :: Python :: Implementation :: PyPy'
+ ],
+ packages=find_packages(),
+ py_modules=["anteater"],
+ entry_points={
+ 'console_scripts': [
+ "anteater = anteater.anteater:main"
+ ]
+ },
+ tests_require=['pytest'],
+ cmdclass={'test': PyTest}
+)