summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorYujun Zhang <zhang.yujunz@zte.com.cn>2016-11-24 14:01:47 +0800
committerYujun Zhang <zhang.yujunz@zte.com.cn>2016-11-24 17:06:18 +0800
commit6200c67619329f686dfb888ac7ef25469375df83 (patch)
tree4065d07425689b410843a21c7390e60d76820eb9 /setup.py
parent213003bb409e02bfab6929ccffe88728a89028e2 (diff)
Use `pbr` for setup configuration
- `pbr` does a bunch of things[1] and is used widely in OpenStack - moved legacy `qtip.py` to scripts in order to keep the project folder clean [1]: http://docs.openstack.org/developer/pbr/#what-it-does Change-Id: I6a9b83883283eaa527e2c3d4cd8d221ee6efca41 Signed-off-by: Yujun Zhang <zhang.yujunz@zte.com.cn>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 2 insertions, 14 deletions
diff --git a/setup.py b/setup.py
index 15900362..ce14d42e 100644
--- a/setup.py
+++ b/setup.py
@@ -2,19 +2,7 @@
from setuptools import setup
-
setup(
- name='qtip-cli',
- version='0.1.dev0',
- description='Platform Performance Benchmarking for OPNFV',
- author='OPNFV',
- author_email='zhang.yujunz@zte.com.cn',
- install_requires=['click', 'pyyaml', 'prettytable'],
- packages=['qtip.cli'],
- entry_points={
- 'console_scripts': ['qtip=qtip.cli.entry:cli']
- },
- license='Apache-2.0',
- keywords="performance benchmark opnfv",
- url="https://wiki.opnfv.org/display/qtip"
+ setup_requires=['pbr>=1.9', 'setuptools>=17.1'],
+ pbr=True,
)