aboutsummaryrefslogtreecommitdiffstats
path: root/charms/trusty/keepalived/hooks/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'charms/trusty/keepalived/hooks/setup.py')
-rw-r--r--charms/trusty/keepalived/hooks/setup.py17
1 files changed, 0 insertions, 17 deletions
diff --git a/charms/trusty/keepalived/hooks/setup.py b/charms/trusty/keepalived/hooks/setup.py
deleted file mode 100644
index 50854d9..0000000
--- a/charms/trusty/keepalived/hooks/setup.py
+++ /dev/null
@@ -1,17 +0,0 @@
-def pre_install():
- """
- Do any setup required before the install hook.
- """
- install_charmhelpers()
-
-
-def install_charmhelpers():
- """
- Install the charmhelpers library, if not present.
- """
- try:
- import charmhelpers # noqa
- except ImportError:
- import subprocess
- subprocess.check_call(['apt-get', 'install', '-y', 'python-pip'])
- subprocess.check_call(['pip', 'install', 'charmhelpers'])